Loading...
 
New Themes

New Themes


Kubrick theme... dropdown

posts: 12 Finland
Everything works ok, almoust, pc-users told me that dropdown menus doesn't work with MS-IE, well same guy told that here with kubrick they work allright. So what i have to do to get them work with IE.confused
posts: 254 Japan

> Everything works ok, almoust, pc-users told me that dropdown menus doesn't work with MS-IE, well same guy told that here with kubrick they work allright. So what i have to do to get them work with IE.confused

I did most of the theme conversion using Windows and checked with IE all along. For me there was no problem with IE and the dropdown (phplayers) menus. Seems like they should work if your Tiki is installed with the default phplayers lib, etc. If you post the URL of the site I'll take a look with IE.

-- Gary

posts: 12 Finland

> > Everything works ok, almoust, pc-users told me that dropdown menus doesn't work with MS-IE, well same guy told that here with kubrick they work allright. So what i have to do to get them work with IE.confused
>
> I did most of the theme conversion using Windows and checked with IE all along. For me there was no problem with IE and the dropdown (phplayers) menus. Seems like they should work if your Tiki is installed with the default phplayers lib, etc. If you post the URL of the site I'll take a look with IE.
>
> — Gary

Ok, url is www.kimmovolley.fi

posts: 254 Japan

> ...
>
> Ok, url is www.kimmovolley.fi

Right, with IE the dropdowns don't display, but they work OK with Opera. I'll try to figure out what the problem is.

-- Gary

posts: 12 Finland

> > ...
> >
> > Ok, url is www.kimmovolley.fi
>
> Right, with IE the dropdowns don't display, but they work OK with Opera. I'll try to figure out what the problem is.
>
> — Gary

Well, they work in pc if you use Firefox too, and here is my css as well, if it helps, it's only file what i changed... Okei, here is not possible to send that file???

posts: 254 Japan

...

Ok, url is www.kimmovolley.fi

Right, with IE the dropdowns don't display, but they work OK with Opera. I'll try to figure out what the problem is.

— Gary

Well, they work in pc if you use Firefox too, and here is my css as well, if it helps, it's only file what i changed... Okei, here is not possible to send that file???


I got your CSS file by saving your page with my browser, but haven't found the problem yet. (Also I turned on forum post attachments here, for future use. smile ). Did you modify tiki.tpl?

Oh oh. A problem here with content going under the right column when using threaded view. . .

-- Gary

posts: 12 Finland

...

Ok, url is www.kimmovolley.fi

Right, with IE the dropdowns don't display, but they work OK with Opera. I'll try to figure out what the problem is.

— Gary

Well, they work in pc if you use Firefox too, and here is my css as well, if it helps, it's only file what i changed... Okei, here is not possible to send that file???


I got your CSS file by saving your page with my browser, but haven't found the problem yet. (Also I turned on forum post attachments here, for future use. smile ). Did you modify tiki.tpl?

Oh oh. A problem here with content going under the right column when using threaded view. . .

-- Gary


Yes, that is a nother problem, and no CSS is only file what i have changed...
Here is my CSS

posts: 254 Japan

...

Ok, url is www.kimmovolley.fi

Right, with IE the dropdowns don't display, but they work OK with Opera. I'll try to figure out what the problem is.

— Gary

Well, they work in pc if you use Firefox too, and here is my css as well, if it helps, it's only file what i changed... Okei, here is not possible to send that file???


I got your CSS file by saving your page with my browser, but haven't found the problem yet. (Also I turned on forum post attachments here, for future use. smile ). Did you modify tiki.tpl?

Oh oh. A problem here with content going under the right column when using threaded view. . .

-- Gary


Yes, that is a nother problem, and no CSS is only file what i have changed...
Here is my CSS


I looked at the CSS file and the saved source of your page. I didn't see anything in the CSS file changes that should cause any trouble.

One difference in the HTML source that I found is that there is an unclosed div, apparently in tiki-top_bar.tpl. There is a div align="center" appearing in the source where tiki-top_bar.tpl is called from tiki.tpl, but no closing tag. This wouldn't cause the phplayersmenu problem, though.

I also noticed that your logo div pops out of and below the tiki-top div when the window is narrowed in IE. That doesn't happen with the themes.tw.o site's kubrick, or other sites that I tested it at. I don't know why that would happen, either. Your logo image is wider, but since it's a background image it should have this kind of effect. In fact I did a test with your page's code and a narrower image, and it still happened.

With no apparent significant differences in the CSS files or templates — apart from the tiki-top_bar.tpl unclosed div — and with all of the phplayers menus CSS files and javascript apparently loading correctly, I really don't know what the problem is. I wonder if it could involve IE's handling of language in the menu.

One test you could make is to check how phplayers menus work in other themes. If they work OK in tikineat or whatever, then it's more clearly a problem with Kubrick. If they don't work correctly in other themes as well, then maybe the problem involves the menu itself somehow.

Anyway, I'll continue to do tests and see if I can find a solution. I didn't expect these themes to be problem free, and the more feedback I get, the more robust they can be.

-- Gary

posts: 12 Finland

Well, i tryed theme moreneat and firefox was okei, but IE doesn't show phplayers menus at all? Only different between your site and my is my version of tiki is 192 yours is 193. I looked RealeaseProsess193 and there is no changed php layers. My server use MySql 4.0.32 and php is 4.1 something.
...H@rtsa

...

Ok, url is www.kimmovolley.fi

Right, with IE the dropdowns don't display, but they work OK with Opera. I'll try to figure out what the problem is.

— Gary

Well, they work in pc if you use Firefox too, and here is my css as well, if it helps, it's only file what i changed... Okei, here is not possible to send that file???


I got your CSS file by saving your page with my browser, but haven't found the problem yet. (Also I turned on forum post attachments here, for future use. smile ). Did you modify tiki.tpl?

Oh oh. A problem here with content going under the right column when using threaded view. . .

-- Gary


Yes, that is a nother problem, and no CSS is only file what i have changed...
Here is my CSS


I looked at the CSS file and the saved source of your page. I didn't see anything in the CSS file changes that should cause any trouble.

One difference in the HTML source that I found is that there is an unclosed div, apparently in tiki-top_bar.tpl. There is a div align="center" appearing in the source where tiki-top_bar.tpl is called from tiki.tpl, but no closing tag. This wouldn't cause the phplayersmenu problem, though.

I also noticed that your logo div pops out of and below the tiki-top div when the window is narrowed in IE. That doesn't happen with the themes.tw.o site's kubrick, or other sites that I tested it at. I don't know why that would happen, either. Your logo image is wider, but since it's a background image it should have this kind of effect. In fact I did a test with your page's code and a narrower image, and it still happened.

With no apparent significant differences in the CSS files or templates — apart from the tiki-top_bar.tpl unclosed div — and with all of the phplayers menus CSS files and javascript apparently loading correctly, I really don't know what the problem is. I wonder if it could involve IE's handling of language in the menu.

One test you could make is to check how phplayers menus work in other themes. If they work OK in tikineat or whatever, then it's more clearly a problem with Kubrick. If they don't work correctly in other themes as well, then maybe the problem involves the menu itself somehow.

Anyway, I'll continue to do tests and see if I can find a solution. I didn't expect these themes to be problem free, and the more feedback I get, the more robust they can be.

-- Gary

posts: 12 Finland

Is there any workaround for this problem?
We have national volleyball club and i have to do somehow those kind of menus... it¨s work ok in firefox 1.501 Safari is working, but there is some flaw in mid section it¨s not white that background gray goes left to right in middle of the page top and bottom is in white background???
I check css in jiggsaw and no errors...
I don¨t hava safari my self but i have three pc- different os and browser... I am stuck please helpfrown

Well, i tryed theme moreneat and firefox was okei, but IE doesn't show phplayers menus at all? Only different between your site and my is my version of tiki is 192 yours is 193. I looked RealeaseProsess193 and there is no changed php layers. My server use MySql 4.0.32 and php is 4.1 something.
...H@rtsa

...

Ok, url is www.kimmovolley.fi

Right, with IE the dropdowns don't display, but they work OK with Opera. I'll try to figure out what the problem is.

— Gary

Well, they work in pc if you use Firefox too, and here is my css as well, if it helps, it's only file what i changed... Okei, here is not possible to send that file???


I got your CSS file by saving your page with my browser, but haven't found the problem yet. (Also I turned on forum post attachments here, for future use. smile ). Did you modify tiki.tpl?

Oh oh. A problem here with content going under the right column when using threaded view. . .

-- Gary


Yes, that is a nother problem, and no CSS is only file what i have changed...
Here is my CSS


I looked at the CSS file and the saved source of your page. I didn't see anything in the CSS file changes that should cause any trouble.

One difference in the HTML source that I found is that there is an unclosed div, apparently in tiki-top_bar.tpl. There is a div align="center" appearing in the source where tiki-top_bar.tpl is called from tiki.tpl, but no closing tag. This wouldn't cause the phplayersmenu problem, though.

I also noticed that your logo div pops out of and below the tiki-top div when the window is narrowed in IE. That doesn't happen with the themes.tw.o site's kubrick, or other sites that I tested it at. I don't know why that would happen, either. Your logo image is wider, but since it's a background image it should have this kind of effect. In fact I did a test with your page's code and a narrower image, and it still happened.

With no apparent significant differences in the CSS files or templates — apart from the tiki-top_bar.tpl unclosed div — and with all of the phplayers menus CSS files and javascript apparently loading correctly, I really don't know what the problem is. I wonder if it could involve IE's handling of language in the menu.

One test you could make is to check how phplayers menus work in other themes. If they work OK in tikineat or whatever, then it's more clearly a problem with Kubrick. If they don't work correctly in other themes as well, then maybe the problem involves the menu itself somehow.

Anyway, I'll continue to do tests and see if I can find a solution. I didn't expect these themes to be problem free, and the more feedback I get, the more robust they can be.

-- Gary

posts: 254 Japan

Is there any workaround for this problem?
We have national volleyball club and i have to do somehow those kind of menus... it¨s work ok in firefox 1.501 Safari is working, but there is some flaw in mid section it¨s not white that background gray goes left to right in middle of the page top and bottom is in white background???
I check css in jiggsaw and no errors...
I don¨t hava safari my self but i have three pc- different os and browser... I am stuck please helpfrown


I don't have a solution for the phplayers menu problem since I can't reproduce it at my sites and my re-checking of the files didn't turn up anything that appeared to be the cause. In the meantime, your options seem to be to not use a phplayers menu, and instead use an ordinary Tiki menu in the side column. A row of important links (normal HTML) could be put across the top also where the phplayers menu currently is — just put the HTML code in tiki.tpl where the phplayers menu tag is.

A second solution is to not use the Kubrick theme until the problems are solved. Not a good solution, but navigation is more important than appearance.

As for the Safari problem, I can't test it directly but will look into adding redundant background color styles. This may be related to the problem with Konqueror that Luci pointed out. I can't say how soon I can do this so it might be better for you to use another style in the meantime.

-- Gary


posts: 2 United Kingdom

Not sure if this is related but:

I am using Firebird (1.5.0.1) on Mac OSX 10.4.5 and had a problem with the drop downs working after instalation but not after modifying various items.

It was resolved after restoring the enabled features (Admin > Features) which matched up (exactly) to the menu options. But I have been unable to reproduce this!


Switch Theme

Layout

Subscribe to Tiki Newsletters!

Delivered fresh to your email inbox!
Newsletter subscribe icon
Don't miss major announcements and other big news!
Contribute to Tiki

Site Config